Email: routine maintenance test

Incident Report for Actuant

Resolved

Test complete. Email was never affected.
Posted Jul 23, 2026 - 10:53 UTC

Identified

Testing manual downtime controls. No emails are affected.
Posted Jul 23, 2026 - 10:51 UTC
This incident affected: Email.