Browser audits: service disruption

Incident Report for Actuant

Resolved

Browser audits is operational again.
Posted Jul 25, 2026 - 09:24 UTC

Investigating

We're investigating an issue causing browser audits to fail upon starting.
Posted Jul 25, 2026 - 09:22 UTC
This incident affected: Browser audits.